Results 1 to 2 of 2

Thread: been seeing a decline in boost over time, where did it go???

  1. #1
    Senior SCH Member vinces427bb's Avatar
    Join Date
    Jul 2011
    Location
    Los Lunas, NM
    Posts
    220

    Question been seeing a decline in boost over time, where did it go???

    I have been seeing a decline in boost over time, where did it go???
    granted i've changed camshafts several times, and just never have gotten close to the same boost levels.
    i know that a better breathing cam can make more power while causing less boost [backpressure].
    but it should have only lost 0.5-2.0# of boost from the changes

    i've also sped up the blower speed with reduced size pulleys to redline the blower speed at the engines redline.
    i've also made sure that the pulleys are not allowing belt slip by treating them with carbinite plasma arc coating, the belt is a maintenance item now as it is sacrificial...
    these changes did not seem to have an effect on the boost, but blower speed is where it should be, and the belt will not slip

    i've moved onto checking for leaking hose connections on tubing from blower to intercooler onto the carb hat.
    also checked the hat to carb gasket.
    i've looked the intercooler over closely for any cracks on fittings, bulging-cracked-torn end caps...
    i checked the airfilter for restriction=no
    i checked the impeller/inducer fins and there was no noticed defects...

    the engine is running great got 12"of steady vacuum at idle speed
    it rev's quickly to redline and feels very strong doing it on only 6#'s of boost...
    i should be seeing another 6-9#'s of boost on my configuration
    this engine was a raging beast when it had 14-15#'s of boost when first put together

    so i've called tech support with this info and that i suspect my open race bypass valve of bleeding off my boost
    they agreed that a torn diaphram and/or vacuum lines/fittings could cause my symptoms
    so i'm going to look into it further = for where is my friggen boost

    did I miss anything ???

  2. #2
    Senior SCH Member vinces427bb's Avatar
    Join Date
    Jul 2011
    Location
    Los Lunas, NM
    Posts
    220
    replaced crank and head pulleys
    and new belt, heat cycled and retightened
    boost is back in the 12#range,
    i'm at a mile high elevation though

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •